Cinema crashing every time i start my animation…please help!
Posted: 12 October 2020 12:44 PM   [ Ignore ]  
Total Posts:  2
Joined  2020-10-12

Hello. 

I have a major problem with some animation i am currently working at: When i add a soft body tag to my mesh, which sits a bit over the plane (collider body), change it to moving mesh and press play cinema always crashes. i tried everything i know of (making the cloner and the subdivions editable + reducing the polygons, grouping all objects into one) but nothing helps. the mesh is not that high polygon so i really don´t know why it crashes every time…if i add just a cube and do the same it works just fine. so it has something to do with the mesh but i can´t really figure out what. is there a way you can help me somehow…thank you!

Profile
 
 
Posted: 12 October 2020 12:52 PM   [ Ignore ]   [ # 1 ]  
Moderator
Avatar
Total Posts:  11648
Joined  2011-03-03

Hi eddi_fuhrmann,

I can’t reproduce it here. Works fine in R23.008. Can you recreate this in a new project file and share it here? (File must be zipped.)

Should I send you an upload link to your Cineversity Private Message Box? Let me know.

Otherwise, crashes are not something for Cineversity; it is always a case for the support.
https://support.maxon.net/index.php

All the best

 Signature 

Dr. Sassi V. Sassmannshausen Ph.D.
Cinema 4D Mentor since 2004
Maxon Master Trainer, VES member

Photography For C4D Artists: 200 Free Tutorials. Texture, Panorama, HDRI, Camera Projection, etc.
https://www.youtube.com/user/DrSassiLA/playlists

Profile
 
 
Posted: 12 October 2020 01:54 PM   [ Ignore ]   [ # 2 ]  
Moderator
Avatar
Total Posts:  11648
Joined  2011-03-03

Hi eddi_fuhrmann,


Thanks a lot for the file.

I can load the scene, enable Softbody and Moving Mesh without a crash.

The project has large elements in it. All are way above the normal scale, going by a normal car wheel. To get reasonable results with dynamic, things should match what we call reality.
This is, of course, only true if the Project settings are set accordingly in the dynamics.

It looks like, and I might be wrong here, that the tires should leave an impression on the ground. To do this with a Plane set by 10x10 segments while the plane’s size is 259157.17 cm * 259157.17 cm seems to speak against my assumption. The wheel size of 866.62 cm and Dynamics set to 100cm are not the perfect match either). Again, I might be off here, but I can’t see any other signs for a different target.


If the imprint of the tires is the key, two main ideas come to mind:

I would split the ground into areas with an imprint and without, to safe recourse in both cases.

The first one is based on Collision Deformer.
https://www.amazon.com/clouddrive/share/xr8a6JHZjFFNNTs27hA4rwIoAXjAN8HGtWCAqXx32nL

The second one is based on the MoGraph Tracer, producing a Spline where a Null object representing the tires’ contact point will move along.
This spline goes into a Proximal Shader and produces information that can be used as a layer mask. This can then shows a layer with no imprint, and the mask unveils the imprint on the floor. If that is doable in your 3rd party render (in your case Arnold), it is not my place to say. The Proximal results might be in need to be baked to work in any 3rd party render. In Cinema 4d, this can be done with a simple bump channel or displacement channel.
https://www.amazon.com/clouddrive/share/h9jQXMDJ17mkDNUN21NK5HwWw5y4mN4hHkORVSAdw8f
or
https://www.amazon.com/clouddrive/share/OYVAufuvP60iv5HWZaDkjk881lFIkbXFRJ9iDSU7mwL

In no way, with this large scale, I would use a Softbody dynamic for it, as it would require millions of polygons to satisfy any useable visual results.

Let me know if you had something completely different in mind.

All the best

 Signature 

Dr. Sassi V. Sassmannshausen Ph.D.
Cinema 4D Mentor since 2004
Maxon Master Trainer, VES member

Photography For C4D Artists: 200 Free Tutorials. Texture, Panorama, HDRI, Camera Projection, etc.
https://www.youtube.com/user/DrSassiLA/playlists

Profile