Migrating Asset Browser Category to New Version
Posted: 21 September 2021 02:07 PM   [ Ignore ]  
Avatar
Total Posts:  80
Joined  2012-05-01

Hello,

Using S24, I created a database with different categories for my current project. When I open a scene that uses those assets, the assets link correctly. When I open those project files in R25, the asset links are all broken (screenshot, attached). I don’t see how to link my R25 Asset Browser to the database I created in S24. Can someone please help?

Thank you.

P.S. I have already gone to Edit > Preferences > Asset Browser and added the databases, but the assets did not automatically relink.

Image Attachments
Screenshot 2021-09-21 150559.png
Profile
 
 
Posted: 21 September 2021 02:25 PM   [ Ignore ]   [ # 1 ]  
Moderator
Avatar
Total Posts:  10500
Joined  2011-03-03

Hi Blasframe,

Please have a look here:

https://help.maxon.net/c4d/r25/en-us/Default.htm#html/PREFSBROWSER-PREF_BROWSER_MAIN_GROUP.html?TocPath=Configuration|Preferences|_____12
Database
When you are in R25 and open the Preferences:

If you have had these files already in an Asset Browser (S24) and used a specific folder, please check
Preferences> Asset Browser> Database

Alternative, if nothing works, but to get you going:
Go to Files> File Assets> Path. Here add the folder(s) that contains your assets. Eventually, a restart might help.
Path
https://help.maxon.net/c4d/r25/en-us/Default.htm#html/PREFSFILES-PREF_FILE_MAIN_GROUP.html#PREF_FILE_TEXPATHS

I hope that helps.
All the best

 Signature 

Dr. Sassi V. Sassmannshausen Ph.D.
Cinema 4D Mentor since 2004

Photography For C4D Artists: 200 Free Tutorials. Texture, Panorama, HDRI, Camera Projection, etc.
https://www.youtube.com/user/DrSassiLA/playlists

Profile
 
 
Posted: 21 September 2021 02:48 PM   [ Ignore ]   [ # 2 ]  
Avatar
Total Posts:  80
Joined  2012-05-01
Dr. Sassi - 21 September 2021 02:25 PM

Hi Blasframe,

Please have a look here:

https://help.maxon.net/c4d/r25/en-us/Default.htm#html/PREFSBROWSER-PREF_BROWSER_MAIN_GROUP.html?TocPath=Configuration|Preferences|_____12
Database
When you are in R25 and open the Preferences:

If you have had these files already in an Asset Browser (S24) and used a specific folder, please check
Preferences> Asset Browser> Database

Alternative, if nothing works, but to get you going:
Go to Files> File Assets> Path. Here add the folder(s) that contains your assets. Eventually, a restart might help.
Path
https://help.maxon.net/c4d/r25/en-us/Default.htm#html/PREFSFILES-PREF_FILE_MAIN_GROUP.html#PREF_FILE_TEXPATHS

I hope that helps.
All the best

Thank you so much, Dr. Sassi! I did the step you suggested with the Preferences> Asset Browser> Database. Your alternative was on the right path (no pun intended): I realized that the missing files weren’t in the Asset Browser database, but rather in a ‘tex’ folder so the paths were relative. I was able to relink them by going to Asset > Globalize Filenames. Thank you so much for your help, as always!

Profile
 
 
Posted: 21 September 2021 03:09 PM   [ Ignore ]   [ # 3 ]  
Moderator
Avatar
Total Posts:  10500
Joined  2011-03-03

You’re very welcome, blastframe!

I’m happy that your project can move on as it should.

Cheers

 Signature 

Dr. Sassi V. Sassmannshausen Ph.D.
Cinema 4D Mentor since 2004

Photography For C4D Artists: 200 Free Tutorials. Texture, Panorama, HDRI, Camera Projection, etc.
https://www.youtube.com/user/DrSassiLA/playlists

Profile