CV-Layer comp update not working
Posted: 27 April 2021 01:36 PM   [ Ignore ]  
Total Posts:  4
Joined  2015-11-09

A few days agoI was really happy to install the new version of layer comps that was compatible with R23.
The script was working fine but cinema was unstable and I was wandering if it was related to this new version.
Today I received a message from CV-toolbox saying that a new version 1.22 was available.
I installed it but I lost most of the layer comps command with the message plugin not found. The only command still available is CV-Active Layer.

Hopefully a new version will correct this one.

I use this tool on every project when it works.

Profile
 
 
Posted: 27 April 2021 01:45 PM   [ Ignore ]   [ # 1 ]  
Total Posts:  5
Joined  2019-09-23

Same here, i’m in a middle of a big project, relying heavily on comps-manager…clicked on update and now i live a miserable life smile

Is it possible to rollback/download the previous 1.21 version?

If someone can upload that it’d be great!

thanks!

Profile
 
 
Posted: 27 April 2021 01:49 PM   [ Ignore ]   [ # 2 ]  
Administrator
Avatar
Total Posts:  406
Joined  2006-01-24

Is there an error message in the console?

1.22 just removed a bunch of debug messages.

Profile
 
 
Posted: 27 April 2021 01:55 PM   [ Ignore ]   [ # 3 ]  
Total Posts:  5
Joined  2019-09-23

Hey Rick, thanks for stepping in!

Here’s a new, cleaned python console log.Seems something is broken.

Traceback (most recent call last):
  File “C:\Program Files\Maxon Cinema 4D R23\plugins\CV-LayerComps\active-layer.pypv”, line 154, in <module>
  File “C:\Program Files\Maxon Cinema 4D R23\plugins\CV-LayerComps\lib\cvtools\__init__.py”, line 25, in <module>
from cvtools import gui, input, layers, utils, menus
ImportError:cannot import name ‘layers’ from ‘cvtools’ (C:\Program Files\Maxon Cinema 4D R23\plugins\CV-LayerComps\lib\cvtools\__init__.py)
  File “C:\Program Files\Maxon Cinema 4D R23\plugins\FD RelinkTextures\FDRelinkTextures.pypv”, line 96
print “File”,  ‘“’ + alltextures[i+1].rsplit(”\\”, 1)[1]+’”’ , “was already in destination folder.”
^ SyntaxError:invalid syntax
DEBUG:cvToolbox:Base Path: C:\Users\User\AppData\Roaming\Maxon\Maxon Cinema 4D R23_DBA5903C\plugins\CV-Toolbox
DEBUG:cvToolbox:Lib Path: lib/37
DEBUG:cvToolbox:Toolbox: C:\Users\User\AppData\Roaming\Maxon\Maxon Cinema 4D R23_DBA5903C\cvToolbox
37
DEBUG:cvToolbox:CV Toolbox v2.17
Traceback (most recent call last):
  File “GePython”, line 7, in <module>
AttributeError:module ‘urllib’ has no attribute ‘urlretrieve’
DEBUG:cvToolbox:Program Started: Checking for new tools!
DEBUG:cvToolbox.core:Write Test succeeded for path C:\Users\User\AppData\Roaming\Maxon\Maxon Cinema 4D R23_DBA5903C\plugins\CV-Toolbox\tbxtest
DEBUG:cvToolbox:CV Toolbox Base Path: C:\Users\User\AppData\Roaming\Maxon\Maxon Cinema 4D R23_DBA5903C\plugins\CV-Toolbox
DEBUG:cvToolbox:Default Install Directory: None
INFO:cvToolbox.core:Retrieved Resource XML from Cineversity
INFO:cvToolbox.core:Parsed Resource XML
DEBUG:cvToolbox:Retrieved XML: <xml.etree.ElementTree.ElementTree object at 0x000002462519FF18>
INFO:cvToolbox.core:Parsed Resource XML
DEBUG:cvToolbox:Checking for new tools since 1619560334, most recent update 1619531580.0

Profile
 
 
Posted: 27 April 2021 02:00 PM   [ Ignore ]   [ # 4 ]  
Administrator
Avatar
Total Posts:  406
Joined  2006-01-24

Sorry - distribution issue. Should be fixed with 1.24 available now.

Profile
 
 
Posted: 27 April 2021 02:06 PM   [ Ignore ]   [ # 5 ]  
Total Posts:  5
Joined  2019-09-23

Beautiful! It’s working perfectly now! I’d kiss you with some epic interstellar music playing on the background smile smile

Thanks for the super speedy solution!

Profile