Multi-instance issue in R20?
Posted: 05 February 2019 12:16 AM   [ Ignore ]  
Total Posts:  54
Joined  2013-11-17

Hi

I’m running an iMac Pro 2017 3.2 GHz with 64 GB RAM and a Radeon Pro Vega 16 GB graphics card.

I thought we could display millions of clones using multi-instance in R20 but I’m finding my machine hangs for minutes/forever when I try to display 50,000+ clones (even if they’re simple spheres and even if I hide the clones the machine still hangs.

Are there some settings I’m missing? Is there a known bug? Is it a Mac thing?

Thanks
Chris

Profile
 
 
Posted: 05 February 2019 09:59 AM   [ Ignore ]   [ # 1 ]  
Moderator
Avatar
Total Posts:  6112
Joined  2011-03-04

Hi Chris,

I have tested this freshly this morning.

That it hand for minutes is indeed unexpected. I have tested it here with a 2015 iMac, 32GB and 4GB graphic. Please note, that the screen capture was done while the screen capture was recording a 5k screen with 30fps.

Please have a look here.
https://www.amazon.com/clouddrive/share/mstSrPZA8JoTX5oMl3UAVIrzAAyQa8q9PmHh2MSnytu

You set up might different, but at least this gives you something comparable. At least it should be no slower than my set up.

Since this is mostly a hardware/technical question, perhaps considering to check this with the support. Minutes sounds long.
https://www.maxon.net/en-us/support/how-can-we-help/


All the best

 Signature 

Dr. Sassi V. Sassmannshausen Ph.D.

Photography For C4D Artists: 200 Free Tutorials: Texture, Panorama, HDRI, Camera Projection, etc.
https://www.youtube.com/user/DrSassiLA/playlists

Profile
 
 
Posted: 05 February 2019 12:52 PM   [ Ignore ]   [ # 2 ]  
Total Posts:  54
Joined  2013-11-17

Thanks Sassi

Have lodged a ticket - Will let you know if there’s an issue.

Profile
 
 
Posted: 05 February 2019 01:29 PM   [ Ignore ]   [ # 3 ]  
Moderator
Avatar
Total Posts:  6112
Joined  2011-03-04

Fingers crossed, Chris, you will get down to seconds rather than minutes.

My best wishes.

 Signature 

Dr. Sassi V. Sassmannshausen Ph.D.

Photography For C4D Artists: 200 Free Tutorials: Texture, Panorama, HDRI, Camera Projection, etc.
https://www.youtube.com/user/DrSassiLA/playlists

Profile
 
 
Posted: 08 February 2019 03:21 PM   [ Ignore ]   [ # 4 ]  
Total Posts:  54
Joined  2013-11-17

FYI-The issue was the use of a Push apart effector and the additional calc required

Cheers

Profile
 
 
Posted: 08 February 2019 05:35 PM   [ Ignore ]   [ # 5 ]  
Moderator
Avatar
Total Posts:  6112
Joined  2011-03-04

Hi Chris,

Another example of why I always should ask for a scene file that can reproduce the problem. Missing information will never lead to good results. Thanks for the additional information.

You gave the information: “…I try to display 50,000+ clones (even if they’re simple spheres and even if I hide the clones the machine still hangs. …”
Well, this is entirely different than just 50K spheres.

All the best

 Signature 

Dr. Sassi V. Sassmannshausen Ph.D.

Photography For C4D Artists: 200 Free Tutorials: Texture, Panorama, HDRI, Camera Projection, etc.
https://www.youtube.com/user/DrSassiLA/playlists

Profile