1 of 2
1
Hair Jitters
Posted: 08 May 2018 06:00 AM   [ Ignore ]  
Total Posts:  18
Joined  2017-07-08

I’m getting tiny hair jitters when using a collider object. I’ve tried many combinations of settings for all related attributes without success. Any suggestions?

Example:

https://youtu.be/FizdVd4S1X4

Thanks

Profile
 
 
Posted: 08 May 2018 08:51 AM   [ Ignore ]   [ # 1 ]  
Moderator
Avatar
Total Posts:  5254
Joined  2011-03-03

Hi chrisjcrocker,

I would request a scene file, but the way you name things, is not motivating me at all. This is not the way I like to work, nor the mood I would like to invite here in the forum.

If you change your mind, share an updated file.

I can’t make sense from a video what the set up is.

All the best

 Signature 

Dr. Sassi V. Sassmannshausen Ph.D.

Photography For C4D Artists: 200 Free Tutorials: Texture, Panorama, HDRI, Camera Projection, etc.
https://www.youtube.com/user/DrSassiLA/playlists

Profile
 
 
Posted: 08 May 2018 09:20 AM   [ Ignore ]   [ # 2 ]  
Total Posts:  18
Joined  2017-07-08

Hi Dr. Sassi

Naming was just a product of frustration, forgot to change it for the video.

Renamed: https://www.dropbox.com/s/ila4528wui9df1d/Issue.c4d?dl=0

Profile
 
 
Posted: 08 May 2018 09:22 AM   [ Ignore ]   [ # 3 ]  
Moderator
Avatar
Total Posts:  5254
Joined  2011-03-03

Thanks a lot, chrisjcrocker, I understand that completely. Thanks for this!

I will check the file!

Talk to you soon.

 Signature 

Dr. Sassi V. Sassmannshausen Ph.D.

Photography For C4D Artists: 200 Free Tutorials: Texture, Panorama, HDRI, Camera Projection, etc.
https://www.youtube.com/user/DrSassiLA/playlists

Profile
 
 
Posted: 08 May 2018 09:30 AM   [ Ignore ]   [ # 4 ]  
Total Posts:  18
Joined  2017-07-08

I was told the issue could be coming from the scale of the mesh, and that C4D dynamics don’t work that well with real world scale. Not sure based on experience if I agree with that assessment, but I did increase the scale in another version, and while that helped the problem a bit, there is still a tiny amount of jitter happening.

Profile
 
 
Posted: 08 May 2018 10:05 AM   [ Ignore ]   [ # 5 ]  
Moderator
Avatar
Total Posts:  5254
Joined  2011-03-03

Thanks for the extra information, chrisjcrocker.

Would you mind testing the “Rest” values? See image below.
Given the expression of the face, I’m certain his animation might be quite erratic, which should have then lower values.

I could even think to connect those values to a velocity in XPresso (via Range Mapper), so they are hight when the velocity is low, vice versa.

Additionally, the Drag value drains energy from the Hair, so they would stop faster.
Steps and Iterations seems to be not the key here, but if I’m not mistaken, you have adjusted them already.

Let me know if that worked for you.

All the best

Image Attachments
ScreenShot2018-05-08.jpg
 Signature 

Dr. Sassi V. Sassmannshausen Ph.D.

Photography For C4D Artists: 200 Free Tutorials: Texture, Panorama, HDRI, Camera Projection, etc.
https://www.youtube.com/user/DrSassiLA/playlists

Profile
 
 
Posted: 08 May 2018 10:08 AM   [ Ignore ]   [ # 6 ]  
Total Posts:  18
Joined  2017-07-08

I have tested the rest values and the only way to get remove the jitter completely is by bringing Rest Hold up to 100%.

I know I could animate that value, and essentially “fix” the problem, but that doesn’t necessarily explain why it’s happening, especially when I’ve had other models that don’t do this.

Profile
 
 
Posted: 08 May 2018 10:13 AM   [ Ignore ]   [ # 7 ]  
Moderator
Avatar
Total Posts:  5254
Joined  2011-03-03

Let’s try again, with a different server:
https://www.amazon.com/clouddrive/share/d9CrbPvZIzyw7wA43HnULHA0DarFoOdsfYW6DoqhQ4i

Not Reset, Rest. Hair: Attribute Manager> Dynamics> Rest Mix or Rest Hold.

https://help.maxon.net/us/#OHAIR-HAIRSTYLE_GROUP_DYNAMICS
scroll down.

Cheers.

 Signature 

Dr. Sassi V. Sassmannshausen Ph.D.

Photography For C4D Artists: 200 Free Tutorials: Texture, Panorama, HDRI, Camera Projection, etc.
https://www.youtube.com/user/DrSassiLA/playlists

Profile
 
 
Posted: 08 May 2018 10:17 AM   [ Ignore ]   [ # 8 ]  
Total Posts:  18
Joined  2017-07-08

Yeah I figured out what you meant. It was confusing at first because your image wasn’t displaying, but once it did I edited my response to:

I have tested the rest values and the only way to remove the jitter completely is by bringing Rest Hold up to 100%.

I know I could animate that value, and essentially “fix” the problem, but that doesn’t necessarily explain why it’s happening, especially when I’ve had other models that don’t do this.

Profile
 
 
Posted: 08 May 2018 10:44 AM   [ Ignore ]   [ # 9 ]  
Moderator
Avatar
Total Posts:  5254
Joined  2011-03-03

Please have a look at the file below, chrisjcrocker,

It is not set to 100%, (rest) but my other suspicion was the Collider itself. I subdivided (smooth 2x) and it seems to be reasonable now. But that is your call what is reasonable for your project, let me know.

Scene file
https://www.amazon.com/clouddrive/share/C7DKVqPUix3FM1TCIrwtMAqgiqfsDJkWHJjPRCxR7bb

All the best

 Signature 

Dr. Sassi V. Sassmannshausen Ph.D.

Photography For C4D Artists: 200 Free Tutorials: Texture, Panorama, HDRI, Camera Projection, etc.
https://www.youtube.com/user/DrSassiLA/playlists

Profile
 
 
Posted: 08 May 2018 10:53 AM   [ Ignore ]   [ # 10 ]  
Total Posts:  18
Joined  2017-07-08

Yeah, it’s still jittering, I think it’s just harder to see because the playback is slower due to the higher subdivision.

Seems like I’ll just have to animate the Rest Hold.

Thanks for trying, I appreciate it.

Profile
 
 
Posted: 08 May 2018 11:12 AM   [ Ignore ]   [ # 11 ]  
Moderator
Avatar
Total Posts:  5254
Joined  2011-03-03

That is very strange, chrisjcrocker.

Of course there is the initial jitter, when the dynamics starts, but then it is solid. You describe a performance loss, then cache it to see it faster.
Cached version with a different point number of the guides (just another test) See link below

Here is what I see:
Screen capture of v01
https://www.amazon.com/clouddrive/share/BjcSZ7GLLfLN8lxhnT15aJ1VLzkxwNB2vEoqT1k3Xib

BTW: If you like me to take the scene file offline, let me know.

My best wishes.

 Signature 

Dr. Sassi V. Sassmannshausen Ph.D.

Photography For C4D Artists: 200 Free Tutorials: Texture, Panorama, HDRI, Camera Projection, etc.
https://www.youtube.com/user/DrSassiLA/playlists

Profile
 
 
Posted: 08 May 2018 11:22 AM   [ Ignore ]   [ # 12 ]  
Total Posts:  18
Joined  2017-07-08

You’re absolutely right. Once I cached and did a playback everything was fine. However playing it back through Dynamic Interaction Redraw was still giving me the issue. It’s bizarre that a cache would clean that up.

Why would that be?

By the way thank you for figuring it out.

Profile
 
 
Posted: 08 May 2018 11:39 AM   [ Ignore ]   [ # 13 ]  
Total Posts:  18
Joined  2017-07-08

Sorry, one more thing. So I just tried to replicate this myself from the point of adding a subdivision x 2 to the collider face, then I cached, but now I’m still getting the jitter issue.

Screen: https://www.dropbox.com/s/qfqb4bcp74fp16x/Still Jittering After Cache.mov?dl=0

Profile
 
 
Posted: 08 May 2018 11:49 AM   [ Ignore ]   [ # 14 ]  
Total Posts:  18
Joined  2017-07-08

I also still get the issue even without an animated null.

Here’s the updated file: https://www.dropbox.com/s/ggcdxtgx4gxsp6g/Issue Updated.c4d?dl=0

Profile
 
 
Posted: 08 May 2018 04:38 PM   [ Ignore ]   [ # 15 ]  
Moderator
Avatar
Total Posts:  5254
Joined  2011-03-03

Hi chrisjcrocker,

I was able to see this jitter again in the file you posted, see below if that works now for you. I have added a short quick push back and fore to see how fast they get to rest.

Scene file:
https://www.amazon.com/clouddrive/share/NFgA0Ypr6Qdr9GA0Ce636gVVa3eHa2qyAiqEBKYix8P
I saved the cache just in case it gets lost, so you can reload it.

Dynamics normally have a limit how long they should try to solve before they stop. There is no given parameter for the Hair dynamics, which would do the trick. Since most of the guides came to a stop, there was that question, why do not for all. The only option to explore it was to select one by one of the problem maker and use the Simulate> Hair Tools> Straighten. Most of them were in peace after the energy was burned (set your Rest state carefully, and use drag/rest options, etc)

However, that wasn’t really my idea to suggest, to pick one by one. But something was dragging on them. I put the Gravity to a much lower value, and things get faster to rest now. I have no idea about your final animation, but perhaps to set this value (Hair> Attribute Manager> Forces> Gravity). Perhaps that might work for you.

All the best

 Signature 

Dr. Sassi V. Sassmannshausen Ph.D.

Photography For C4D Artists: 200 Free Tutorials: Texture, Panorama, HDRI, Camera Projection, etc.
https://www.youtube.com/user/DrSassiLA/playlists

Profile
 
 
   
1 of 2
1