Grass alpha (multi pass?)
Posted: 10 November 2017 10:14 AM   [ Ignore ]  
Total Posts:  7
Joined  2017-05-04

So there’s a feature in the Hair Render for Multi-Pass. I’ve added the Post Effects option to the Multi-Pass render selection in the Standard renderer but I’m still not getting an alpha for my grass. I just get a solid black frame. I have no idea what I’m doing wrong but it’s becoming pretty frustrating because I can’t seem to find a clear answer. Can anyone help me out on this?

Image Attachments
Hair 01.jpgHair 02.jpg
Profile
 
 
Posted: 10 November 2017 10:38 AM   [ Ignore ]   [ # 1 ]  
Moderator
Avatar
Total Posts:  4710
Joined  2011-03-03

Hi Sean,

Please have a look at this file.
Scene file
https://www.amazon.com/clouddrive/share/BxjEVShflItg6OZQvHSpkJlfT1VaeaameqerHTyNaNd

Render it to the Picture Viewer, go then to Layer>Single Pass, and let me know if there is something useful for you.

All the best

 Signature 

Dr. Sassi V. Sassmannshausen Ph.D.

Photography For C4D Artists: 200 Free Tutorials: Texture, Panorama, HDRI, Camera Projection, etc.
https://www.youtube.com/user/DrSassiLA/playlists

Profile
 
 
Posted: 10 November 2017 11:56 AM   [ Ignore ]   [ # 2 ]  
Total Posts:  7
Joined  2017-05-04

That did it! Looks like I needed to have the RGBA Image effect in there as well. You saved my weekend!

Profile
 
 
Posted: 10 November 2017 12:10 PM   [ Ignore ]   [ # 3 ]  
Total Posts:  7
Joined  2017-05-04

For some reason though, adding Global Illumination kills the effect. The Hair, depth, alpha and multiply channels all turn out blank. Any idea why that might be?

Profile
 
 
Posted: 10 November 2017 01:51 PM   [ Ignore ]   [ # 4 ]  
Moderator
Avatar
Total Posts:  4710
Joined  2011-03-03

Sean, since the manual isn’t really pointing in any direction, my estimate is, that the Grass Shader has no option to change the results into anything else other than a volumetric effect. In Hair one can generate different “Hair” results, e.g., Square. In Grass that option is not given. The Grass will turn into any color that the light produces in GI so far I can see it (white lights results in gray grass), perhaps not really the result one is after.

The only way I can see to make it work: render two passes. I’m not certain if there is more, or that the support has maybe a trick available.
https://www.maxon.net/en-us/support/how-can-we-help/


All the best

 Signature 

Dr. Sassi V. Sassmannshausen Ph.D.

Photography For C4D Artists: 200 Free Tutorials: Texture, Panorama, HDRI, Camera Projection, etc.
https://www.youtube.com/user/DrSassiLA/playlists

Profile
 
 
Posted: 11 November 2017 09:10 AM   [ Ignore ]   [ # 5 ]  
Total Posts:  7
Joined  2017-05-04

Thanks for your help Dr Sassi. I guess I’ll have to render out the 2 passes since my scene needs GI. It’s better than no option at all wink

Profile
 
 
Posted: 11 November 2017 09:34 AM   [ Ignore ]   [ # 6 ]  
Moderator
Avatar
Total Posts:  4710
Joined  2011-03-03

Hi Sean,

Yes, sorry, I tried the usual suspects, but no change in R19 in this regard. I hope I do not missed something.

Perhaps the Take System will help to make this less of an effort.

If you render the GI scene, maybe an invisible polygon in the gras area with a green material might help to create the “green-spill” to objects, if that is needed.

My best wishes for the project

 Signature 

Dr. Sassi V. Sassmannshausen Ph.D.

Photography For C4D Artists: 200 Free Tutorials: Texture, Panorama, HDRI, Camera Projection, etc.
https://www.youtube.com/user/DrSassiLA/playlists

Profile